OpenWRT IPv6: Konfigurasi Sederhana

From mUTU
Jump to: navigation, search

Konfigurasi sederhana

  • Masuk ke Administration
  • Network > IPv6 ULA-Prefix > isi dengan alokasi IPv6 yang kita miliki.
  • Network > LAN > Edit > IPv6 assignment length > isi dengan 64 jika di perlukan
  • Network > LAN > Edit > DHCP Server > IPv6 Settings >
Router Advertisement-Service      server mode
DHCPv6-Service                    server mode
NDP-Proxy                         disable
DHCPv6-Mode                       stateless + statefull
Always announce default router
Announced DNS servers
Announced DNS domains


Konfigurasi CLI

/etc/config/olsrd

config olsrd
	option IpVersion '6and4'
	option FIBMetric 'flat'
	option LinkQualityLevel '2'
	option LinkQualityAlgorithm 'etx_ff'
	option OlsrPort '698'
	option Willingness '3'
	option NatThreshold '1.0'

config LoadPlugin
	option library 'olsrd_arprefresh.so.0.1'

config LoadPlugin
	option library 'olsrd_dyn_gw.so.0.5'

config LoadPlugin
	option library 'olsrd_httpinfo.so.0.1'
	option port '1978'
	list Net '0.0.0.0 0.0.0.0'

config LoadPlugin
	option library 'olsrd_nameservice.so.0.3'
	option ignore '0'
	option latlon_file '/var/run/latlon.js'
	option hosts_file '/etc/hosts'
	option resolv_file '/etc/resolv.conf'

config LoadPlugin
	option library 'olsrd_txtinfo.so.0.1'
	option accept '0.0.0.0'

config Interface
	option ignore '0'
	option interface 'MESH'
	option Mode 'mesh'

config InterfaceDefaults
	option Mode 'mesh'

config Hna4
	option netaddr '192.168.1.0'
	option netmask '255.255.255.0'

config Hna6
	option netaddr '2001:123:123::'
	option prefix '64'

config LoadPlugin
	option library 'olsrd_bmf.so.1.7.0'
	option ignore '1'

config LoadPlugin
	option library 'olsrd_dot_draw.so.0.3'
	option ignore '1'

config LoadPlugin
	option library 'olsrd_dyn_gw_plain.so.0.4'
	option ignore '1'

config LoadPlugin
	option library 'olsrd_jsoninfo.so.0.0'
	option ignore '1'

config LoadPlugin
	option library 'olsrd_mdns.so.1.0.1'
	option ignore '1'

config LoadPlugin
	option library 'olsrd_p2pd.so.0.1.0'
	option ignore '1'

config LoadPlugin
	option library 'olsrd_pgraph.so.1.1'
	option ignore '1'

/etc/config/olsrd6

Pastikan file /etc/config/olsrd6 di delete.

Yang kita perlu pindahkan ke /etc/config/olsrd


config LoadPlugin
 	option library 'olsrd_txtinfo.so.0.1' 
	option accept '::'
	option port '2007'

config Hna6
	option netaddr '2001:123:123::'
	option prefix '64'

/etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix '2001:123:123::/60'

config interface 'lan'
	option ifname 'eth0.1'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '64'
config interface 'lan'
	option ifname 'eth0'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '64'
	option ip6prefix '2001:222:222:1::/64'
	option ip6addr '2001:222:222:1::1'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config interface '3G'
	option _orig_ifname '3G'
	option _orig_bridge 'false'
	option proto '3g'
	option service 'umts'
	option apn 'internet'
	option ipv6 '1'
	option peerdns '0'
	option dns '8.8.8.8 8.8.4.4'
	option device '/dev/ttyUSB0'

config interface 'MESH'
	option proto 'static'
	option ipaddr '10.123.123.123'
	option netmask '255.0.0.0'
	option ip6gw '2001:123:123::1'
	option ip6prefix '2001:123:123::/64'
	option ip6addr '2001:222:222::222'

/etc/network/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'pci0000:00/0000:00:00.0'
	option htmode 'HT20'
	option txpower '20'
	option country 'US'
	option channel '1'

config wifi-iface
	option device 'radio0'
	option encryption 'none'
	option mode 'adhoc'
	option bssid '02:CA:FF:EE:BA:BE'
	option network 'MESH'
	option ssid 'MESH'